记给apache加php支持

作者:Chilau 发布于:2012-7-23 19:01 分类:software

今天我调试自己写的程序,发现php5.4自带的开发者服务器变量数组居然不对(坑爹,真坑爹!害我找了半天原因....),只好用apache.
由于apache是我以前XP系统留下的,我直接运行就出现了这样的提示
0.png
配置文件第三十五行.打开,修改.
1.png
是由于盘符没对上号,现在的是A,把C改为A,保存.再运行.
2.png
这次是因为PHP的原因.由于php5.4没有apache的filter所以自然无法加载.又改吧.
3.png


4.png
把第491行注释掉.再在下面加上如图中的那三行,用CGI方式来运行.再运行..
5.png
根据返回的信息来看,是有程序已经占用了80端口,所以无法开始监听.
继续改.
6.png
监听10080端口.
7.png
权限不足..原来没给虚拟目录CGI执行权限.
再加.
8.png
允许所有访问,允许执行CGI.
9.png
OK了.
这样做执行效率不高,不过自己用来调试练手可以了,相对于IIS来说apache+cgi配置更简单,DIY也更自由.



« VS2008 不能将参数 1 从“const char [10]”转换为“const wchar_t *” | C语言代码:去除源文件中的注释»

发表评论: